$re = '/[A-Z0-9\!\-]{3}/';
$str = 'Aaa
z
AAA
B';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);