re = /'(?:\\.|'(?=\w)|[^'])*'/m
str = '\'builder\'s margin\' means the percentage stated in \'Item 8\' of Schedule 1;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end