#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)\b((?:(?!(\u0627|\u064A|\u0648))(?:[\u0600-\u06FF]))+?)\b"
Local $sString = "تفقدت نظارتي حين استيقظت صباحا فلم اجدها في مكانها وبحثت عنها في كل مكان دون ان اعثر لها علي اثر يا الهي كيف ساخرج اليوم من البيت واواجه النهار " & @CRLF & _
" وتناهي الي من الخارج صوت نقار الخشب فوق جذع شجره قريبه فاسرعت الي الباب وفتحته واذا ضوء النهار يبهر بصري فاغلقت عيني وهتفت ايها النقار اين انت " & @CRLF & _
" وحاولت عبثا ان افتح عيني وانا اقول عفوا لا استطيع ان افتح عيني ان الضوء يعميني"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")