$re = '/([a-z\s]+)([0-9]+)/i';
$str = 'Legal Leaves 2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);