$re = '/[^<>]*(?=<[^<>]*>)/s';
$str = '<span>text_01<b>text_02</b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);