using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test(\d)string\1";
string input = @"test1string2 , test2string2 and test3string3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}