$re = '/<Profile((?!<\/Profile)[\s\S])*?<limit>[\s\S]*?<\/Profile>/';
$str = '<Profile sr="prof101" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof102" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof103" ve="2">
<flags>2</flags>
<limit>true</limit>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>
<Profile sr="prof104" ve="2">
<flags>2</flags>
<Event sr="con0" ve="2">
</Event>
<App sr="con1" ve="2">
</App>
</Profile>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);