$re = '/^\d\d(?:[ .,]\d\d?)*$/m';
$str = 'Нужно захватывать такие виды оквэдов (1 === \\d{1}):
11
11.1
11,1
11.11
11,11
11.11.1
11,11,1
11.11.11
11,11,11
11 11.11 11.11.11
11 11,11 11,11,11
Недопустимы:
11.
11,
11.1.
11,1,
11.11.
11,11,
11.11.1.
11,11,1,
11.11.11.
11,11,11,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);