$re = '/(?=.*(USD))(?(1)\d+|[a-zA-Z])/m';
$str = ' 100 USD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);