$re = '/^(?!(\d+x\d+)).*/m';
$str = '555x555asdawe234rwf
2x2xvxsdd
555aseeaweqwe
555xwae';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);