re = /(?:[^\/]|(?<!\/)\/(?!\/))*МОСКВА(?:[^\/]|(?<!\/)\/(?!\/))*/m
str = 'какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА дом 10/2 // еще что-то'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end