import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\/[^\\W_]+(?:\\*|\\/\\*)?|\\*)+$|^\\/\\*?$";
final String string = "# Should match:\n"
+ "/\n"
+ "/*\n"
+ "/abc\n"
+ "/abc*\n"
+ "/abc/*\n"
+ "/abc/def\n"
+ "/abc/def/xyz\n"
+ "/abc/def/*\n\n"
+ "# Should not match:\n"
+ "/abc/\n"
+ "/abc*/\n"
+ "/abc/def*\n"
+ "/abc*/def\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}