# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\w+ \w+\((?:\n(?!^\w+ \w+\().*)*\)(?=\s*^paragraph_b)//gm;t' <<< "some random texts (100+ lines)
bbb
...
ttt
some random texts
ccc
...
fff
paragraph_a A_story(
...
some random texts adfsasdsd
...
)
paragraph_a A_story(
...
some random texts adfsasdsd
...
)
paragraph_a A_story(
...
some random texts adfsasdsd
...
)
paragraph_b different_story(
...
some random texts
...
)"