re = /^(?!.*(myFunction|myOtherFunction|yetAnotherFunction)).*$/
str = 'thisOneIsNotCovered
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end