re = /address\s+(?<ip>\d+\.\d+\.\d+\.\d+)/m
str = 'The server-side authentication level policy does not allow the user XXXXX SID (XXXXX) from address 192.168.10.100 to activate DCOM server. Please raise the activation authentication level at least to RPC_C_AUTHN_LEVEL_PKT_INTEGRITY in client application.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end