package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ab{0,2}c`)
var str = `abc ac xabbbcz bc abbc abbbbbc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}