re = /<img[\. .=":;a-zA-Z0-9ĀČĒĢĪĶĻŅŌŖŠŪŽzāčēģīķļņōŗšūž]+(height:[ 0-9]+px)+/
str = '<div style="height: 300px"><img title="Ā" src="t.jpg" style="width:1000px; height: 300px"><img src="t.jpg" style="width:1000px; height: 500px"><eee src="t.jpg" style="width:1000px; height: 500px">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end