import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z^\\.]+\\.(?:[^\\[]+| ?)\\[[^\\]]+[^\\s]+)";
final String string = "VB.Bar-1[TEST-Insert.2]Val_1 = B.Bar-1[PC83-AB2.1]In1 && B.Bar-1[PC83-AB2.1]In2\n"
+ "VB.Bilozerka-1[TEST-Insert.2]Val_2 = B.Bilozerka-1[ТП1.1]Пуск_захисту && B.Bilozerka-1[ТП1.1]Спрацьовування_захисту_iнвертора\n"
+ "VA.Bar-1[TEST-Insert.3]Val_3 = A.Bar-1[DirisA40.1]V3 && A.Bar-1[DirisA40.1]P\n"
+ "VA.Dashev-1[TEST-Insert.3]Val_1 = A.Dashev-1[ТП-5.2 AC]C_active_power && B.Dashev-1[ТП-5.2 AC]PV_input_power";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}