$re = '/\b([a-z])\1\1\1.+?\b/mi';
$str = 'AAAAA likes apples, but BBBBB likes bananas. Their phone numbers are ffffr and ggggh.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);