$re = '/(?<=(?:<\/[^<>]+>|<[^<>]+\/>|^)[^<>]*)([a-zа-яё-]+)/ui';
$str = 'фыв фыв<pb/>Перекати-поле фыв<s>Pиo-дe-Жaнeйpo. фыв</s> Перекати-поле фыв фыв;<span>поле</span>полe фыв';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);