import re
regex = re.compile(r"^(\d{1,4})[\/|-|.\S](\d{1,2})[\/|-|.|\S](\d{1,4})[\T|\s](\d{1,2})[\:](\d{1,2})[\S|:](\d{2})?[\:|\s|.|Z]?(\d{7})?(?:AM)?(?:PM)?$", flags=re.MULTILINE)
test_str = ("Validated\n\n"
"01.10.2008 17:04\n"
"10/1/2008 5:04 AM\n"
"01/10/2008 17:04\n"
"01.10.2008 17:04:32\n"
"10/1/2008 5:04:32 PM\n\n"
"2008-10-01T17:04:32.0000000\n"
"2008-10-01T17:04:32\n"
"2008-10-01 17:04:32Z\n\n\n\n\n"
"Not Works!\n"
"01.10.2008 17:04 '\n"
"10/1/2008 5:04 PM '\n"
"01/10/2008 17:04 ' \n"
"01.10.2008 17:04:32 '\n"
"10/1/2008 5:04:32 PM '\n\n"
"2008-10-01T17:04:32.0000000 '\n"
"2008-10-01T17:04:32 ' \n"
"2008-10-01 17:04:32Z '\n\n"
"Validate!\n"
"01.10.2008 17:04\n\n"
"10/1/2008 5:04 PM\n"
"01/10/2008 17:04\n"
"01.10.2008 17:04:32\n"
"10/1/2008 5:04:32 PM\n\n"
"2008-10-01T17:04:32.0000000\n"
"2008-10-01T17:04:32\n"
"2008-10-01 17:04:32Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")