#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?$"
Local $sString = "// valid urls" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"http://google.com/" & @CRLF & _
"https://google.com/" & @CRLF & _
"www.google.com" & @CRLF & _
"google.com" & @CRLF & _
"https://www.google.com.ua" & @CRLF & _
"http://www.google.com.ua" & @CRLF & _
"http://google.com.ua" & @CRLF & _
"https://google.com.ua/" & @CRLF & _
"www.google.com.ua" & @CRLF & _
"google.com.ua" & @CRLF & _
"https://mail.google.com" & @CRLF & _
"http://mail.google.com" & @CRLF & _
"mail.google.com" & @CRLF & _
"" & @CRLF & _
"// invalid urls" & @CRLF & _
"http://google" & @CRLF & _
"https://google.c" & @CRLF & _
"google" & @CRLF & _
"google." & @CRLF & _
".google" & @CRLF & _
".google.com" & @CRLF & _
"goole.c" & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")