re = /(?=.*hello)(----.+?----)/m
str = '----hello, how are you----
----how are you,hello, how are you----
----how are you hello, how are you----
----hello how are you , how are you----
----how are you , how are you----
---hello how are you , how are you---
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end