package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\A(((?:[\w+\-].?)+)@([a-z\d\-]+(?:\.[a-z]+)*\.[a-z]+))\z`)
var str = `johnburke1235@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}