# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"({[^}]+})+, -- (.+)"
test_str = ("{ spell = 126, type = \"ability\"}, -- Eye of Kilrogg\n"
" { spell = 172, type = \"ability\", requiresTarget = true, debuff = true}, -- Corruption\n"
" { spell = 686, type = \"ability\", requiresTarget = true}, -- Shadow Bolt\n"
" { spell = 698, type = \"ability\"}, -- Ritual of Summoning\n"
" { spell = 702, type = \"ability\", requiresTarget = true, debuff = true}, -- Curse of Weakness\n"
" { spell = 710, type = \"ability\", requiresTarget = true, debuff = true}, -- Banish\n"
" { spell = 755, type = \"ability\"}, -- Health Funnel\n"
" { spell = 980, type = \"ability\", requiresTarget = true, debuff = true}, -- Agony\n"
" { spell = 1714, type = \"ability\", requiresTarget = true, debuff = true}, -- Curse of Tongues\n"
" { spell = 3110, type = \"ability\", requiresTarget = true}, -- Firebolt\n"
" { spell = 3716, type = \"ability\", requiresTarget = true}, -- Consuming Shadows\n"
" { spell = 5484, type = \"ability\"}, -- Howl of Terror\n"
" { spell = 5782, type = \"ability\", requiresTarget = true, debuff = true}, -- Fear\n"
" { spell = 6358, type = \"ability\", requiresTarget = true}, -- Seduction\n"
" { spell = 6360, type = \"ability\", requiresTarget = true}, -- Whiplash\n"
" { spell = 6789, type = \"ability\", requiresTarget = true, talent = 14 }, -- Mortal Coil")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.