package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`8=+D`)
var str = `8============D`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}