$re = '/\n.*?(keyword 1).*?(keyword 2).*?$/sm';
$str = 'garbage I don\'t need - garbage I don\'t need
timestamp - date - server info - \'keyword 1\' - data
more data more data more data more data
more data more data more data more data
more data more data \'keyword 2\' - last bit of data
garbage I don\'t need - garbage I don\'t need';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);