re = /^(?<operator>eq|ne|gt|lt|ge|le|ct|bt):(?<firstValue>-?[0-9]+)(-(?<secondValue>-?[0-9]+))?$/m
str = 'eq:54
bt:52-56
lt:-1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end