const regex = /(([\+]|[0][0])[0-9]{2})[\s\-\\\/]*([0-9]+)[\s\-\\\/]*([0-9]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([\\+]|[0][0])[0-9]{2})[\\s\\-\\\\\\\/]*([0-9]+)[\\s\\-\\\\\\\/]*([0-9]+)', 'g')
const str = `1234/5678911
+99 1234 123456
0099 1234 123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}