$re = '/hostname=(?P<BadDomainNamesDetected>\".*\")/m';
$str = 'hostname="google.com" hostname="trademe.co.nz" hostname="baidu.cn"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);