$re = '/^(?=.*\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\w\d\s:])([^\s]){8,16}$/m';
$str = '/^(?=.*\\d)(?=.*[A-Z])(?=.*[a-z])(?=.*[^\\w\\d\\s:])([^\\s]){8,16}$/gm
_}24I:9t58Tu?m@e
|YlzEc|1
#m_4xF%t"Bu5jeb$
Password1!
12345678aA
^@},^@},^@},
12345678aA@
12345678 aA@
12345678aA@
AbCdEfGhIi
abcdefgh123
ABCDEFGH1234
[
[
{
"content": "_}24I:9t58Tu?m@e",
"isParticipating": true,
"groupNum": 0,
"startPos": 66,
"endPos": 82
},
{
"content": "e",
"isParticipating": true,
"groupNum": 1,
"startPos": 81,
"endPos": 82
}
],
[
{
"content": "|YlzEc|1",
"isParticipating": true,
"groupNum": 0,
"startPos": 83,
"endPos": 91
},
{
"content": "1",
"isParticipating": true,
"groupNum": 1,
"startPos": 90,
"endPos": 91
}
],
[
{
"content": "#m_4xF%t\\"Bu5jeb$",
"isParticipating": true,
"groupNum": 0,
"startPos": 92,
"endPos": 108
},
{
"content": "$",
"isParticipating": true,
"groupNum": 1,
"startPos": 107,
"endPos": 108
}
],
[
{
"content": "Password1!",
"isParticipating": true,
"groupNum": 0,
"startPos": 109,
"endPos": 119
},
{
"content": "!",
"isParticipating": true,
"groupNum": 1,
"startPos": 118,
"endPos": 119
}
]
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);