$re = '/\.\d+/m';
$str = '5.55
5.5577
5.557788
5.55778899
5.
5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);