const regex = /#(\w+)\(*([\w\d\s\=\>\<\[\]\"\'\)\(\&\|\*\+\-\%\@\^\?\/\$\.\!]*)\)\)*{((?:(?R)|.)*?)}#/smg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(\\w+)\\(*([\\w\\d\\s\\=\\>\\<\\[\\]\\"\\\'\\)\\(\\&\\|\\*\\+\\-\\%\\@\\^\\?\\\/\\$\\.\\!]*)\\)\\)*{((?:(?R)|.)*?)}#', 'smg')
const str = `<html>
#v123w(r(!@3o=?w){
<div></div>
}#
#131ie_w(13gf\$>&*()(*&){
<div></div>
}#
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}