import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#(\\w+)\\(([\\w\\s=><[\\]\"')(&|*+%@^?\\/$.!-]*)\\)\\{(.+?)\\}#";
final String string = "<html>\n"
+ "#v123w(r(!@3o=?w){\n"
+ "<div></div>\n"
+ "}#\n"
+ "#131ie_w(13gf$>&*()(*&){\n"
+ "<div></div>\n"
+ "}#\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}