$re = '/(?<=\().*(?=\);)/m';
$str = '...;(Flat in the west region of the city (HEN distinct) - sunny 84m);(House in the east....;)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);