$re = '/(Jan(uary)?|Feb(ruary)?|Mar(ch)?|Apr(il)?|May|Jun(e)?|Jul(y)?|Aug(ust)?|Sep(tember)?|Oct(ober)?|Nov(ember)?| Dec(ember)?)(,?)(\s\d{4})/m';
$str = 'MIT Sample:
SOME ASPECTS OF RADIATION INDUCED NUCLEATION IN WATER
by
Chih-Ping Tso
B.Tech., Loughborough University of Technology, United Kingdom
(1968)
Submitted in Partial Fulfillment of
the Requirements for the Degree of
Master of Science
at the
Massachusetts Institute of Technology
August 1970
Signature of Author
Department of Nuclear Engineering
Certified by
Thesis Supervisor
Accepted by
Chairman, Departmental Committee
Archives on Graduate Students
MASS. INST. TECH.
SEP 21 1970
LIBRARIES
--------------------------------------
Virginia Tech Sample:
FORMATTING VARIABLES AND TYPEFACE VARIATIONS
OF
DOT-MATRIX PRINT AND THEIR EFFECT
ON
READING COMPREHENSION AND READING SPEED
by
James A. Holmes
Dissertation submitted to the Faculty of the
Virginia Polytechnic Institute and State University
in partial fulfillment of the requirements for the degree of
DOCTOR OF EDUCATION
in
Vocational and Technical Education
March, 1986
Blacksburg, Virginia';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);