$re = '/^(?:([abc])(?!.*\1))+$/m';
$str = 'a
ab
ac
abc
aac
aa
aba
abcb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);