re = /^[^\[\]]+\[(?<something>[^\[\]]+)\][^\[\]]+$/m
str = 'The [answer] is six.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end