re = /\?[\w-]+=[\w.|()+%-]+(?:&[\w-]+=[\w.|()+%-]+)*/m
str = '?tn_cid=280&tn_fk_specifications_planten_planttype=Groene%20kamer+planten|hangplanten|tuinplanten&tn_fk_ae-waterbehoefte=Weinig%20(2x%20per%20maand)&tn_fk_specifications_planten_plantheight=30%20-%2035%20cm&tn_fk_ae-hoogte-plant=Kleine%20planten%20(tot%2040%20cm)&tn_fk_ae-prijs=16.99-16.99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end