$re = '/^(?!\d+$)[^>#<@*\n]+$/m';
$str = 'Some text
4455
Some text >
More here 245 %%%^^&&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);