# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<date>\d{4}-\d{2}-\d{2})\s*(?<time>\d{2}:\d{2}:\d{2}:\d{3})\s*\[\s*(?<level>\w*)\s*(?<module>.*?)\s*\]\s*(?<message>.*)$"
test_str = ("2021-09-27 09:28:25:778 [ debug nextcloud.sync.database ] [ OCC::SyncJournalDb::tableColumns ]: Columns in the current journal: QVector(\"path\", \"chunk\", \"transferid\", \"errorcount\", \"size\", \"modtime\", \"contentChecksum\")\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: SQL exec \"PRAGMA table_info('conflicts');\"\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database ] [ OCC::SyncJournalDb::tableColumns ]: Columns in the current journal: QVector(\"path\", \"baseFileId\", \"baseEtag\", \"baseModtime\", \"basePath\")\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: SQL exec \"CREATE INDEX IF NOT EXISTS metadata_e2e_id ON metadata(e2eMangledName);\"\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: Last exec affected 0 rows.\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database ] [ OCC::SyncJournalDb::commitInternal ]: Transaction commit \"update database structure: add e2eMangledName index\" and starting new transaction\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: SQL exec \"PRAGMA table_info('blacklist');\"\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database ] [ OCC::SyncJournalDb::tableColumns ]: Columns in the current journal: QVector(\"path\", \"lastTryEtag\", \"lastTryModtime\", \"retrycount\", \"errorstring\", \"lastTryTime\", \"ignoreDuration\", \"renameTarget\", \"errorCategory\", \"requestId\")\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: SQL exec \"CREATE INDEX IF NOT EXISTS blacklist_index ON blacklist(path collate nocase);\"\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: Last exec affected 0 rows.\n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database ] [ OCC::SyncJournalDb::commitInternal ]: Transaction commit \"checkConnect End\" \n"
"2021-09-27 09:28:25:778 [ debug nextcloud.sync.database.sql ] [ OCC::SqlQuery::exec ]: SQL exec \"SELECT COUNT(*) FROM metadata\"\n"
"2021-09-27 09:28:25:794 [ info nextcloud.gui.folder.manager ]: Adding folder to Folder Map OCC::Folder(0x2677fdf3ee0) \"1\"\n"
"2021-09-27 09:28:25:795 [ info nextcloud.gui.folder.manager ]: Schedule folder \"1\" to sync!\n"
"2021-09-27 09:28:25:795 [ info nextcloud.gui.folder.manager ]: Folder is not ready to sync, not scheduled!\n"
"2021-09-27 09:28:25:797 [ info nextcloud.gui.application ]: Sync state changed for folder \"\" : \"Not yet Started\"\n"
"2021-09-27 09:28:25:797 [ info nextcloud.sync.clientproxy ]: Set proxy configuration to use the preferred system proxy for http tcp connections\n"
"2021-09-27 09:28:25:801 [ debug nextcloud.gui.updater ] [ OCC::Updater::create ]: QUrl(\"https://updates.nextcloud.org/client/?version=3.3.4.20210920&platform=win32&osRelease=windows&osVersion=server2016&kernelVersion=10.0.17763&oem=Nextcloud&buildArch=x86_64¤tArch=x86_64&versionsuffix=stable-Win64&updatesegment=43&msi=true\")\n"
"2021-09-27 09:28:26:533 [ info nextcloud.sync.credentials.webflow ]: Fetch from keychain!\n"
"2021-09-27 09:28:26:536 [ info nextcloud.gui.folder.navigationpane ]: Explorer Cloud storage provider: saving path \"\" to CLSID \"{5cefc208-e391-444c-af93-61c636da9853}\"\n"
"2021-09-27 09:28:26:537 [ info nextcloud.gui.socketapi ]: New connection QLocalSocket(0x267027e4570)\n"
"2021-09-27 09:28:26:538 [ warning nextcloud.sync.credentials.keychainchunk ]: Unable to read \"Nextcloud_clientCertificatePEM:0\" chunk \"0\" \"Password entry not found\"\n"
"2021-09-27 09:28:26:538 [ warning nextcloud.sync.credentials.keychainchunk ]: Unable to read \"Nextcloud_clientKeyPEM\" chunk \"0\" \"Password entry not found\"\n"
"2021-09-27 09:28:26:538 [ warning nextcloud.sync.credentials.webflow ]: Unable to read client key \"Password entry not found\"\n"
"2021-09-27 09:28:26:538 [ warning nextcloud.sync.credentials.keychainchunk ]: Unable to read \"Nextcloud_su_mssrv01_clientCaCertificatePEM0\" chunk \"0\" \"Password entry not found\"\n"
"2021-09-27 09:28:26:538 [ warning nextcloud.sync.credentials.webflow ]: Unable to read client CA cert slot \"0\" \"Password entry not found\"\n"
"2021-09-27 09:28:26:538 [ debug nextcloud.sync.account ] [ OCC::Account::slotCredentialsFetched ]: User id already fetched.\n"
"2021-09-27 09:28:26:539 [ info nextcloud.gui.account.state ]: Fetched credentials for \"\" attempting to connect\n"
"2021-09-27 09:28:26:539 [ debug nextcloud.sync.account ] [ OCC::Account::resetNetworkAccessManager ]: Resetting QNAM\n"
"2021-09-27 09:28:26:539 [ info nextcloud.sync.credentials.webflow ]: Get QNAM\n"
"2021-09-27 09:28:26:539 [ debug nextcloud.sync.connectionvalidator ] [ OCC::ConnectionValidator::checkServerAndAuth ]: Checking server and authentication\n"
"2021-09-27 09:28:26:539 [ debug nextcloud.sync.connectionvalidator ] [ OCC::ConnectionValidator::checkServerAndAuth ]: Trying to look up system proxy\n"
"2021-09-27 09:28:26:540 [ info nextcloud.sync.connectionvalidator ]: No system proxy set by OS\n"
"2021-09-27 09:28:26:541 [ info nextcloud.sync.accessmanager ]: 2 \"\" \"\" has X-Request-ID \"75765e8e-2b52-4dd9-b67b-62b450feafdc\"\n"
"2021-09-27 09:28:26:541 [ debug nextcloud.sync.cookiejar ] [ OCC::CookieJar::cookiesForUrl ]: QUrl(\"\") requests: (QNetworkCookie(\"nc_sameSiteCookielax=true; secure; HttpOnly; expires=Fri, 31-Dec-2100 23:59:59 GMT), QNetworkCookie(\"nc_sameSiteCookiestrict=true; secure; HttpOnly; expires=Fri, 31-Dec-2100 23:59:59 GMT))\n"
"2021-09-27 09:28:26:541 [ info nextcloud.sync.networkjob ]: OCC::CheckServerJob created for \"\" + \"status.php\" \"OCC::ConnectionValidator\"\n"
"2021-09-27 09:28:26:795 [ debug nextcloud.gui.folderwatcher ] [ OCC::FolderWatcher::pathIsIgnored ]: * Ignoring file \"D:/Shared/NextcloudMirror/.owncloudsync.log\"\n"
"2021-09-27 09:28:28:826 [ info nextcloud.gui.updater ]: Checking for available update\n"
"2021-09-27 09:28:28:826 [ info nextcloud.sync.accessmanager ]: 2 \"\" \"https://updates.nextcloud.org/client/?version=3.3.4.20210920&platform=win32&osRelease=windows&osVersion=server2016&kernelVersion=10.0.17763&oem=Nextcloud&buildArch=x86_64¤tArch=x86_64&versionsuffix=stable-Win64&updatesegment=43&msi=true\" has X-Request-ID \"2fbd3d8d-a4e6-486f-b0f7-dbd441225cd3\"\n"
"2021-09-27 09:28:28:826 [ debug nextcloud.sync.cookiejar ] [ OCC::CookieJar::cookiesForUrl ]: QUrl(\"https://updates.nextcloud.org/client/?version=3.3.4.20210920&platform=win32&osRelease=windows&osVersion=server2016&kernelVersion=10.0.17763&oem=Nextcloud&buildArch=x86_64¤tArch=x86_64&versionsuffix=stable-Win64&updatesegment=43&msi=true\") requests: ()\n"
"2021-09-27 09:28:29:638 [ info nextcloud.sync.credentials.webflow ]: request finished")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.