#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)#Section(\d+)\b(?:(?!#Section\d).)*\bJack/M,(\d+\h+[-+]?\d+(?:\.\d+)?(?:\s+\d+\h+[-+]?\d+(?:\.\d+)?)*)"
Local $sString = "#Section250342,Main,First/HS/12345/Jack/M,200010 10.00 200011 -2.00," & @CRLF & _
"#Section250322,Main,First/HS/12345/Aaron/N,200010 17.00," & @CRLF & _
"#Section250399,Main,First/HS/12345/Jimmy/N,200010 12.00," & @CRLF & _
"#Section251234,Main,First/HS/12345/Jack/M,200011 11.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")