$re = '/\d+(?::\d+)*$/m';
$str = '[\'abd
the dog
4:45
1234 total
123
6:31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);