re = /\b([A-Za-z])([^@\s]*)([A-Za-z]@[A-Za-z])([^@\s.]*)([A-Za-z])\b/m
str = 'ramesh@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end