re = /^\d{4}-\d{2}-\d{2} \d\d:\d\d:\d\d\.\d+\s+(?P<timestame>\d{4}-\d{2}-\d{2}T\d\d:\d\d:\d\d\.\d+Z)\b/m
str = '2022-04-03 14:37:25.101991388 2022-04-03T12:37:25.101Z CLOSE host=::ffff:218.92.0.192 port=21590 fd=4 time=20.015 bytes=26
2022-04-03 14:38:07.723962122 2022-04-03T12:38:07.723Z ACCEPT host=::ffff:218.92.0.192 port=64475 fd=4 n=1/4096'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end