import Foundation
let pattern = #"(TDT\+20\+LA8031\+\+\+LA)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"UNA:+.? ' UNB+UNOA:4+TAM:JJ+APIAR:ZZ+170911:1456+1709111456++APIS' UNG+PAXLST+TAM:JJ+APIAR:ZZ+170911:1456+1709111456+UN+D:02B' UNH+CRW001+PAXLST:D:02B:UN:IATA' BGM+250+DC:1.0' TDT+20+LA8031+++LA' LOC+125+GRU' DTM+189:1709091315:201' LOC+87+AEP' DTM+232:1709091610:201' NAD+FM+++RAVAZZOLLI ABUD SILVA:MARCELO+454 AGOSTINHO DE FARIA+SAO PAULO+SP+0828 0 100+BRA' ATT+2++M' DTM+329:680426' NAT+2+BRA' DOC+P:110:109+F0722522' DTM+36:251102' LOC+91+BRA' NAD+FM+++BOCK PEREIRA:RICARDO+209 NHU GUACU AP 104+SAO PAULO+SP+04625001+BRA' ATT+2++M' DTM+329:800513' NAT+2+BRA' DOC+P:110:109+FR676533' DTM+36:261003' LOC+91+BRA' NAD+FM+++BARBOSA DA SILVA:THIAGO+RUA PELOTAS 323 AP 143+SAO PAULO+SP+04012 903 +BRA'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)