#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\S+\s\S+\s\s|^\S+\s\s)((?![-])|(?![_]))"
Local $sString = "Washington, DC November 27, 2019" & @CRLF & _
"USDA Truck Rate Report" & @CRLF & _
"" & @CRLF & _
"WA_FV190 " & @CRLF & _
"" & @CRLF & _
"FIRST PRICE RANGE FOR WEEK OF NOVEMBER 20-26 2019 " & @CRLF & _
"SECOND PRICE MOSTLY FOR TUESDAY NOVEMBER 26 2019 " & @CRLF & _
"" & @CRLF & _
"PERCENTAGE OF CHANGE FROM TUESDAY NOVEMBER 19 2019 SHOWN IN (). " & @CRLF & _
"" & @CRLF & _
"In areas where rates are based on package rates, per-load rates were " & @CRLF & _
"derived by multiplying the package rate by the number of packages in " & @CRLF & _
"the most usual load in a 48-53 foot trailer." & @CRLF & _
"" & @CRLF & _
"CENTRAL AND WESTERN ARIZONA " & @CRLF & _
"-- LETTUCE, BROCCOLI, CAULIFLOWER, ROMAINE AND LEAF LETTUCE SLIGHT SHORTAGE " & @CRLF & _
"-- " & @CRLF & _
"" & @CRLF & _
"ATLANTA 5100 5500 " & @CRLF & _
"BALTIMORE 6300 6600 " & @CRLF & _
"BOSTON 7000 7300 " & @CRLF & _
"CHICAGO 4500 4900 " & @CRLF & _
"DALLAS 3400 3800 " & @CRLF & _
"MIAMI 6400 6700 " & @CRLF & _
"NEW YORK 6600 6900 " & @CRLF & _
"PHILADELPHIA 6400 6700 " & @CRLF & _
"" & @CRLF & _
" 2019 2018 " & @CRLF & _
"" & @CRLF & _
" NOV 17-23 NOV 18-24 " & @CRLF & _
"" & @CRLF & _
"U.S. 25,701 22,956 " & @CRLF & _
"IMPORTS 13,653 15,699 " & @CRLF & _
" ------------ -------------- " & @CRLF & _
"sum 39,354 38,655 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")