re = /(".+?")|(,)/m
str = '1234,Cake,,"Smith,John",,"Status: Acknowledge,Accept",,Red,,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end