# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<\/?[^\0- !-@[-`{-\x7f][^\0- !-,:-@[-`{-\x7f]*+(?!>)//gm;t' <<< "<div></div><input></input"