import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:31(\\/|-|\\.)(?:0?[13578]|1[02]))\\1|(?:(?:29|30)(\\/|-|\\.)(?:0?[1,3-9]|1[0-2])\\2))(?:(?:1[6-9]|[2-9]\\d)?\\d{2})(?=\\W)|\\b(?:29(\\/|-|\\.)0?2\\3(?:(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])?|(?:(?:16|[2468][048]|[3579][26])00)?)))(?=\\W)|\\b(?:0?[1-9]|1\\d|2[0-8])(\\/|-|\\.)(?:(?:0?[1-9])|(?:1[0-2]))(\\4)?(?:(?:1[6-9]|[2-9]\\d)?\\d{2})?(?=\\b)";
final String string = "26.11\n"
+ "26.11.2016\n"
+ "29.2.2000\n"
+ "29/2/2015\n"
+ "abcde 27.11.2016 fghi \n"
+ "01/02/2000\n"
+ "31/01/2000\n"
+ "32/01/2000\n"
+ "01/1/2000\n"
+ "01/1/01\n"
+ "27.01.\n"
+ "01.12\n"
+ "fasd 24.10.\n"
+ "28/02/2001\n"
+ "30/04/2000\n"
+ "31/04/2000\n"
+ "31/07/2000\n"
+ "31/08/2000\n"
+ "31/09/2000\n"
+ "01/12/2000\n\n"
+ "01/15/2000\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}